[Fixed in 2.763] Microphone mute icon not changing

Hi,

I just switched from the last stable version to new experimental version (v 2.760).
I noticed that whenever I pressed the microphone mute button, the microphone volume was correctly set to 0, but the icon was not changing. In the stable version, the icon was turning red as expected.

I managed to fix that by replacing the

return " "

in the applescript by

return inputVolume

Now everything seems to be working fine.
I don't know if those return " " were intended or not...

Anyway, thank you very much for your work @GoldenChaos.

ahhh of course the “harmless” change I slipped in causes a regression... :sweat_smile:

Will be fixed in the next experimental version!

Fixed in GC-BTT 2.763!

Thank you!

The icon now disappears when I try to enable it.

When I open settings and enable microphone mute, the icon shows briefly in the touchbar and then disappears. Disabling it and then re-enabling it gives the same behaviour.

Actually the icon only appears when an app using the mic is running.
Try running Skype for example.

1 Like

This is the correct answer!

@jeroen if there's an app that uses the microphone but the mic mute key isn't showing up for you when it's running, let me know and I'll add it to the list of microphone-using apps that it checks to enable the key.

Imprint | Privacy Policy