Firefox starting in safe-mode when launched via keyboard shortcut

Describe the bug
I have mapped Firefox to option-w but it only starts in safe-mode this way. Switching to Firefox when it already runs works though. Same behavior with Thunderbird.


Device information:

  • Type of Mac: Macbook Air 2018
  • macOS version: Mojave 10.14.5
  • BetterTouchTool version: 3.05

Have the same problem, solved by map the shortcut to "Execute Terminal Command". For firefox, the command is "open -a firefox"

Strange, when I press the "run script"-button this works, but when I hit the keyboard shortcut I get the same error as before. Does it really work for you when firefox is not running and you hit the keyboard shortcut?

yes , on my side, it works.
macOS version: Mojave 10.14.6
BetterTouchTool version: 3.202(1378)

Got the same versions of macOS and BTT, but doesn't work for me unfortunately, but thanks anyway!

Was having the same issue even with Hammerspoon. So this is not a BetterTouchTool bug. I found the solution in Hammerspoon's repository Basically you cannot use 'alt' or 'option' as shortcut modifier as it triggers firefox's safe mode. I know... bummer

OK, didn't know about this. Thank you very much!