Extra scroll on swipe / disable three-finger scroll on Trackpad

On a Macbook trackpad. I use three-finger swipe-up and swipe-down to travel between any app tabs. This used to work fine on previous OS versions. Currently on Catalina it does not. I get an extra scroll when doing the three-finger swipe up on every tab. Usually after the three-finger swipe up event.

I know that I could activate the three-finger drag lock to avoid the scroll but I already use tap to lock while dragging.

A possible solution for this could be giving the option to turn off the three-finger swipe on the trackpad configuration.

MacBook Trackpad

  • Type of Mac: Macbook Pro
  • macOS version: Catalina
  • BetterTouchTool version: 3.379

I'm suddenly having this kind of behaviour as well. I just noticed it while ago. If I completely disable BTT and restart without starting it, it still persist.

Without BTT If I'm using only MacOS built in gestures I'm getting Mission Control with four fingers as well, even if it's set to three fingers.

If I disable all gestures I get scroll with 2, 3, and 4 fingers.

I'm On MacBook Pro 2015, MacOS 10.15.7 Catalina, BTT 3.540