Escape key trigger not working with Hyper key in Terminal

I set up a hyper key trigger (via Caps Lock) to use a named trigger that presses the Escape key. This seems to work, except in, where I want to use Escape (via Caps Lock) to enter vi command mode. This seems to be the case on two different systems I've tried. Is there some reason that this doesn't work in Could there be something running that's conflicting somehow? I tried adding a Show Notification action to the Escape trigger, and that's certainly running, but the Escape action just doesn't seem to be doing anything useful.

Curiously, sending Escape via an AppleScript action (tell application "System Events" to key code 53) works for me. ?!?

how are you sending the esc key in BTT? Using the standard shortcut sending functionality or via the esc predefined action? (the action will include any currently pressed modifier keys, thus might not be what you need)

1 Like

Yes, I'd been using the pre-defined action, whoops! That was it. Just sending a regular old Escape via the keyboard shortcut action does the job. Thanks.