Enabling App's native touchbar for specific app not working

I would like to set up far2l so that when it's active, it's native touchbar is shown.
As far as I understand, there is a setting for that: "Show App default touchbar".
When I add far2l to the list of apps and switch that setting, nothing is happening.
Am I doing something wrong or is it a bug?

  • Type of Mac: Macbook Pro 16"
  • macOS version: 11.6 Big Sur
  • BetterTouchTool version: 3.581 (1724)

Have you tried having the far2l window active, clicking the BTT menubar icon and selecting "Disable BTT for... --> Disable BetterTouchTool for active app"?

I've tried that now and BTT behaves weirdly when I do that.
Initially it doesn't do anything, then whenever I click on far2l, BTT pops up a modal dialog like "required parameter missing" and then crashes after a while. When restarted, it's in globally disabled mode.

The reason might be because far2l is not a "proper" mac app but implemented in a nonstandard way and BTT fails to handle it.