Drawings / Mouse Gestures unreliable

I have noticed this after updating to BTT 4.333 and macOS Sonoma. When initiating Drawings / Mouse Gestures, the red dot is frequently at a different position than the mouse cursor, which messes up the gesture and makes it invalid.

I’m using gestures with the built-in trackpad. I don’t have an external mouse or trackpad.

  • Type of Mac: M1 MacBook Air
  • macOS version: 14.1.1 (23B81)
  • BetterTouchTool version: 4.336 (43350).

This is getting worse. It now happens most of the time, so often that trying to use the feature is effectively worse than not having it. Please let me know if you think it can be fixed, as this is the only feature of BTT I use.

I’m not asking for a time-frame, I understand these things take time, I’d just like to get some information (is this a known issue; is it being worked on?) so I can decide how to proceed.

Thank you.

1 Like

Unfortunately I can not yet reproduce the issue. What kind of trigger are you using to start the drawing recognition?

Thank you for the response. I have both TipTap Left (1 Finger Fix) and TipTap Right (1 Finger Fix) start the recognition.

Something else which may provide a clue. Sometimes I try doing it really slowly: do the gesture to start recognition; stop; draw. When the recognition stars, the red dot is at the same place as the cursor, but when I start the gesture then it suddenly jumps as if it started somewhere else.

Hey, Andreas.

My issue is not quite the same as with @swoosh, but is somewhat similar. And yes, gesture drawing and recognition has been acting up lately.

For me it happens rarely and doesn't seem to impact recognition, only the visual side. But from time to time (especially after the mouse has been touched for a while) I would start drawing, but there would appear a phantom starting point beyond the drawing area that would be drawn to connect to the actual starting point.

Again, for me this doesn't seem to affect the recognition.

Other than that, drawings stop being, well, drawn when switching desktops. And start being drawn again after any app on this desktop enters fullscreen mode. But then I would switch desktop again and, again, they won't be drawn there until I enter and exit fullscreen. Doesn't impact recognition either.

What does impact recognition is that it's generally not very reliable. First of all for diagonal lines. I've somehow tweaked the :arrow_upper_left: and :arrow_lower_right: gestures to work 99 percent of the times, but the :arrow_lower_left: one keeps getting mistaken for ← or, worse, :arrow_upper_left:. ((

Hopes it gets sorted one day.
Thank you for your work!

I can confirm!
Basically I use three gestures:

  • Down
  • Down, then Up
  • Down, then Right

Often "Down" will not be recognized.

Or it will be recognized as "Down, then Up" which is really weird because my cursor didn't even move a single pixel up.

Also, often "Down, then Right" will be recognized as "Down" only.

I tried tested with several values for regonation triggers but it doesn't help.

Also it fails a most of the time if I run the same gestures twice in a short amount of time: Run a gesture, wait < 1 second, run it again -> fail.

Mouse gestures were smooth like one or two versions before, so I assume something had changed here.

I think I found what's causing this! Will upload a new alpha in about an hour.

1 Like

I think alpha 4.338 alpha should fix it!

Hey Andreas,

thanks for the fast fix. Most issues are resolved, but still the DOWN gesture is unreliable.
I quickly captured a screen video demonstrating the issue. Have a look here:

If you encounter gesture problems I recommend to delete the recorded and record again, also make sure to add multiple variations/recordings for the same gesture.

For straight lines it also makes sense to enable this (if you have multiple):

Last, make sure the allowed rotation is not set to a too high value:


maximum rotation was already set to 30, I reduced it to 10 it seems to help.
Still, executing the DOWN migration multiple times will only make it work the first time.

// Edit: It's fine. I've configured a delay of 1 second in the actions what is probably causing this. Why did I set up a delay? Because I use this right-click-gesture to open new tabs in a web browser. Once in a while, even though the gesture works flawlessly, the context menu will shop up. Adding a delay + space key presssing will immediately close the context menu after. I never found out why sometimes the context menu appears.

// Edit 2: After playing around a bit more I'd still say gesture recognition is a bit unreliable, especially DOWN, the UP - but I can't tell when exactly it will fail. It was definitely better a few versions ago on my machine.

Have you tried re-recording the gesture or add another variation to it? (In general straight line recognition should be much better with the current versions compared to the older ones)

I only can speak for myself of course, but straight lines worked without a problem in the past.

Disabling rotation recognition for all my gestures seems to improve it a lot. Maybe this was the issue. Maybe it's worth to disable this by default? I don't think many users need their gestures working if rotated.

At the moment it seems like I can't create new gestures - or add more variants to existing gestures.
If I try to draw some gestures into the area that says "Draw the gesture your want to use here...", nothing happens. Doesn't matter what mouse button I use.

Dropbox - gesture.png - Simplify your life

That's weird, I seem to be able to add drawings. Which version of macOS are you running?

14.1.1 (23B81)

Same here. Are you doing a standard mouse click & drag to draw?

Never mind.

I did set the drawing line color to transparent, because usually I don't need to see the gestures I'm drawing. I didn't know this has effect to the configuration drawing area, too.

So the gestures I ran were captured, but just not visible.

// Thanks for the support. For me everything is working like a charm again now.

Interesting (always some use case I didn't think about) :slight_smile: I'll add a check for transparent color in the recorder window to prevent this in the future.

// v4.339 alpha defaults to the system accent color if transparency is detected (for rendering the previews and while creating new drawings)

1 Like

That works :+1: thank you!

I did set the drawing line color to transparent, because usually I don't need to see the gestures I'm drawing.

Great idea. I’m going to use that.