Downgrade to version 2.428 not possible with new MB air M2

When setting up my new MacBook Air m2 OS X 12.4 I have problems to use BTT.
I bought a license back in 2016. Last version I used on my old MBP (late 11, OSX 10.13.6) was BTT 2.427. It worked totally fine.

When I try to downgrade to the last working version it won't work (see screenshot below).
I tried to restart. I cannot find the version in the dl directory.
I don't know what to do.

I‘ll check what’s wrong.

However you REALLy should not use that old version on a Apple Silicon Macbook. It will run ok, but it will slow down your whole computer because it’s not build for the new CPU.

so my only option would be to buy a new license? or is there an opportunity to upgrade to a lifelong version?

BTT doesn’t have an upgrade system, so yes for a new version you‘d need a new license.

If you want to continue using the old one, you can grab it here for now, until I have fixed the downgrade mechanism:

This is also happening on my intel i5 2017 MacBook Pro for the last 3 days, it mentions an update error and to try later.

I think downgrades should now be working again!