double keypress in terminal with shortcut

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

I went to the alpha page and that version (3.332) is less than the one I have (3.346)

Describe the bug

In a terminal if I control down arrow, quickly followed by control left btt causes a double control left keypress. This only happens when I have a control left keyboard shortcut mapped to option left.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Device information:

  • Type of Mac: MacBook Pro (Retina, Mid 2012)
  • macOS version: 10.14.6 (18G4032)
  • BetterTouchTool version: 3.346

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Repro steps:

  1. make a keyboard shortcut for all apps that maps Control-left to Option-left
  2. open
  3. type "Fee fi fo fum" do not hit enter
  4. slowly type control-down and then control-left
  5. notice how the cursor moves as expected, one word left
  6. now hold down control and quickly hit down and then left
  7. notice how the cursor moves TWO words left
  8. in BTT click "shortcut is enabled" on the control-left shortcut to disable it
  9. in terminal now do the quick control-down and control left and see that it works as it should.

This also happens in emacs -nw -q in a terminal and emacs in its own window too. But this is the simplest repro steps I could find.

Do you maybe have secure keyboard entry enabled in terminal?

Not sure whether this could be caused by it, but it sounds like a strange issue and possibly it's related.

I wish it were that.
This happens in iTerm2 and also Emacs when it's running in its own window.

Weird. I can't seem to reproduce it here, but haven't tried it on my 10.14 machine yet.

Possibly try the shortcut sending compatibility mode for the affected apps:

Thanks so much for the quick replies and your help, I super appreciate it.

I can't repo when I add a shortcut for iTerm2 either. but when I add the shortcut for "All Apps", that's when it doesn't work for me. All Apps doesn't seem to have a "compatibility mode" option.

I guess for now a good workaround is to add this shortcut for most of the apps I use. But I wish it worked under "All Apps"

Thanks again

That's interesting. There shouldn't be a difference between global and app specific shortcuts :-/
I'll think about this.