Disabling smart quotes in Shell Script editor

Under the "Execute Shell Script/Task" action, when I edit a script, smart quotes are enabled. The first time when this occurred, I was at a total loss why the script did not work. Each time when I enter/edit a quotation mark now, I have to copy and paste from an external text editor.

Can you disable smart quotes for the BTT Shell Script editor? I think this is the default behavior in standard code editors, and is in fact the case for the BTT AppleScript editor. I know I can globally turn smart quotes off under System Preferences -> Keyboard -> Text, but I would rather keep the smart quotes on for many other applications.