Disable trackpad when mouse is attached

I would like to have the option to disable the trackpad when i connect my Bluetooth mouse to my MacBook Pro. Is there a way in Better Touch Tool to do that?

While looking through feature requests I found this and an earlier request for the same thing here: Disable Trackpad when mouse is conntected

Yes, this is the same request also done by me.
Can tis be done? I am already looking to do this myself with a little background program that detects of a mouse (wired or Bluetooth) is connected and the disables the trackpad.

I would like this feature, too! In the meantime, I serendipitously discovered that if I had also my Logitech USB receiver plugged-in (but not used), the disable-trackpad-on-mouse connection would work for that dual-mode mouse, even when using it with bluetooth! Not an idea solution, but working sufficiently well!

This is possible in MacOS Accessibility settings i believe

Hi There,

I have read the article but it for Catalina it isn't working.
All the articles I read are for earlier OSX versions. The same procedure doesn't work for Catalina.
If you have an article about this for Catalina please share this.


@EifX

The checkbox is cheked but nothing happens

Not sure, might be a macos bug. Maybe try uplug and replug the mouse? I've never used this feature i just know it's there

Yep that option should work - as long as you are talking about the built in trackpad and not an external Magic Trackpad.

The strangest thing happened. I clicked the checkbox on and nothing happened.
Then I thought it is because Better Touch tool was installed and something got in the way.
So I removed BT and restarted my Mac and the trackpad could not be pressed any more. I mean it didn't click when I pressed the trackpad. And the Bluetooth mouse was working. Then I switched it off again and the trackpad worked normally. Now I switched it on again and the trackpad is responding to my touch so it doesn't switch off. Am I missing something here?

Yes, I'm working with the build-in trackpad But it seems to have a mind of its own.
I'm using a Logitech MX Anywhere Bluetooth mouse. I also uninstalled the Logitech software for mac for this mouse so it wouldn't interfere with the Apple OSX stuff. Bit still the trackpad is. always on.
I read a note about maybe it is a bug How can I verify that?

Imprint | Privacy Policy