Disable trackpad clicking sound for AquaTouch touchbar?


I just updated the AquaTouch preset to the latest (v3.5.8a) and now every time I click something it triggers the trackpad click (which it didn't do previously). How would I go about turning this off? It's so annoying. If I can't figure it out i'll probs just delete BTT altogether.

Thanks in advance.

Probably you have the haptic feedback option enabled:

Thanks for the response. For some reason both were set to "Super Strong Feedback" but even after changing them to "No Feedback" it was still the same. I tried it with the other options aswell but it didn't change at all. restarted the app to refresh and all that but no good.

mh I don’t think Aqua Touch adds extra haptics but I’m not sure. Maybe try a different preset and see whether the haptic feedback remains.

@yuuiko do you know of any recent haptic feedback changes in Aqua Touch?

Aquatouch does have extra haptics for things like gestures, hold accents and a different click for the QuickStrip. It also controls that option in BTT, I didn't set it to change it back during regular use but maybe something is doing that.

I recommend turning haptics off from the QuickControls (switches icon on the four-button pallette on the right), as this should shut off everything

It was already off in the QuickControls and I had tried turning that on and off a couple of times aswell but this time it seemed to do the trick. Thanks!

1 Like

Might need to restart BTT after clicking the switch. AQT should do that automatically... does it?

Yeh it does.

1 Like