Disable Smart Zoom on specific Application

The Problem: Apple Smart Zoom on Magic Mouse is a good e nice feature that works pretty well with the most Application, but some Apps don't seem to deal properly with it.
I've searched a workaround but all I've found is to disable Smart Zoom in the Magic Mouse Settings tab. That's no solution since I would have to turn it on and off every time i swap App.
My specific problem is that MS Word seems to be ultra sensitive to the double tap and it will zoom in randomly. To zoom out, differently from Safari, you have to reset the zoom percentage via Menu bar or via Ctrl + alt and scroll, what just an approximate choice allows (I like to work with precisely 150% zoom)

The Request: Please add checkboxes in the BTT that will allow to disable specific Magic Mouse Settings (in concreto Smart Zoom) just in specific apps.

Thank you and thank you for your (already) awesome BTT, I can't use a Mac without it!

I have the same problem with the Magic Mouse when I use Photoshop. If I just barely touch the top of the mouse, the document in PS will either zoom way out or zoom way in. I just want to shut that off for specific programs.

Imprint | Privacy Policy