Disable inertia while using magic mouse for certain programs / fix InDesign scrolling/zooming

So the problem Im having is that InDesign in combination with a Magic Mouse is working like a total mess.
Mouse interactions like zooming and scrolling are way too sensitive and sometimes they jump from one point to another while scrolling.

Im not really sure how to describe the problem, but I hope its understandable like that.
Im pretty sure im not the only one with this issue as I had this problem on totally different workstations.

I discovered that disabling inertia in the usability settings makes it way better, its not working perfect but its not as bad as before.
But disabling it forever is also not a solution as scrolling without inertia is really bad.

My question is if there is any way to disable inertia only for certain programs or if anyone who experienced the same issue might have another maybe even better fix.