Disable horizontal single finger scrolling β€” not working on Mojave

mojave

#1

Hi,
The following settings don't work for me:

  • Disable horizontal single finger scrolling for 'Global' (override by pressing FN)
  • Disable horizontal single finger scrolling for 'Microsoft Excel' (override by pressing FN)
    or any other app.

I'm running version 2.669, with Mac OS 10.14.2 (Mojave), on an iMac using a Magic Mouse. I have also tried a few other recent older versions.

BTT is allowed to control computer through Security & Privacy.

I also can't disable horizontal scrolling with the command line in Terminalβ€”this doesn't work:
defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool NO
just FYI.

Thanks,
noah


#2

Using v2.669 in High Sierra. I find that setting the horizontal single finger scrolling to "No action" does not work. Not sure if this is the correct method. Other settings (keyboard shortcuts) do work. The unintended horizontal scrolling in Excel and other apps is very annoying.


#3

I second this. After the demise of MagicPrefs I've been dying for something that will kill the unwanted horizontal scrolling in OS X.


#4

I think it should be working again in the latest alpha version of BTT. Would be great if you'd test that. (Get via "Check for alpha version updates")


#5

I updated to 2.689 (995), but alas, no luck in any application β€” the horizontal scrolling remains. Thanks for working on this.


#6

Do you have any gestures configured in BTT?
I think BTT may turn off the whole touch handling for Magic Mice if no gesture is configured at all.


#7

Hi, yes, I tried adding gestures, which work with perfect functionality β€” 3- and 4-finger tap are working great β€” but the horizontal scrolling continued regardless of toggling on or off.

I am now on a MacBook Pro 2017 for a few weeks until I return home and can try the Magic Mouse again, but the same issues persist on macOS Mojave with the built-in Trackpad. Thanks again.


#8

Ah wait, this setting only affects Magic Mice. Trackpads are intentionally left out. (There is no such thing as single finger horizontal scrolling on the trackpads)


#9

I've been wishing for the ability to disable Magic Mouse horizontal scrolling since I purchased my iMac. I just tried BTT version 2.697 (iMac Pro Mojave 10.14.2) and wasn't able to get BTT to override single finger horizontal scrolling in any application. It does recognize it and any action (Except no action) seems to work.

Hoping for some solution...

Thanks,


#10


#11

Hello Andreas,
I finally returned home after a month away and was able to try out your update. The Magic Mouse works perfectly, regardless of whether there is a gesture configured or not.

Thank you! I bought lifetime updates and look forward to using this. It will help greatly in the future.

Noah


#12

You are the man! Works perfectly:)

Thanks!


#13

Guys,

Is there a way to make global "disable horizontal single finger scrolling" works on Mojave?
Mine does not work at all. Tried everything, regular, alpha, beta version, with and without gesture, etc.. Nothing!

I'm using Macbook Pro + Magic Mouse.

Tks.
Almir