Disable horizontal scrolling while touching magic mouse 2

Hi Guys. I'm using Magic Mouse 2 and i found a problem that it scrolls while i'm clicking. I found a code for terminal to fix this and now i'm looking for another comand,
While i gently touching my mouse, it sometimes scrolls horizontally, Is there a way to fix this? Maybe block or make touch pressure different?

Or maybe someone know how to prevent scrolling with movement of my finger upper part (which under nail, don't know how to explain)

When selecting an app in BTT you can choose to disable horizontal single finger scrolling:

I'm a video editor, so i need horizontal scrolling, but i don't need playhead to move when i'm clicking or gently touching my mouse. Maybe there some command?

Imprint | Privacy Policy