Disable Horizontal Scrolling on Magic Mouse worked and now it doesn't

I have all finger horizontal swiping disabled it stopped the scrolling, a few hours later it just started horizontal scrolling again. It just stopped working. I have seen numerous posts about this on this community page and bug reports and no answers. Please help!

  • Type of Mac: imac
  • macOS version: Catalina
  • BetterTouchTool version: 3.225

Just be aware that BTT only disables horizontal single finger scrolling on Magic Mouse, other types of horizontal scrolls can not be disabled with BTT.

I haven't experienced problems with that myself but will monitor the issue.

I have every swiping disabled and yesterday it worked for a few hours, and it stopped working. I just don't understand that. There was another post that said the same thing happened to them. People are pleading for help.

BTT just doesn't have such a feature at the moment (but it would be possible to add something like it). These advanced settings are to configure BTT gestures and tell them to prevent scrolling while performing the gestures. They are not related to horizontal scrolling.

Darn it. It's a very common problem for designers, and would be appreciated to be added. thank you so much for your help

But maybe disabling single finger horizontal scrolling already helps for now?

You can disable that by selecting "All Apps" (or the app you want) on the left, then activating the checkbox:

THAT IS THE MAGIC! Thank you SO much!

This has been helpful but I think an option to disable all horizontal scrolling should be added (regardless of how many fingers), there seems to be a lot of demand for it. I find that I tend to rest a second finger on the mouse thus activating the scrolling - a hard habit to break : )

1 Like

For me, anyway, this doesn't always seem to work @Andreas_Hegenberg, which makes me wonder if I'm misunderstanding how to use it properly.

My issue is with the RStudio IDE, a multi-tab development environment for R. For some reason, if your mouse pointer is in the tab bar, horizontally scrolling does't just roll the tabs along, it switches focus to an entirely different editor window! So, deep in thought about one problem, you're suddenly whisked away to ten tabs over. So frustrating.

When I "Disable Single Finger Horizontal Scrolling" with BTT on the RStudio app, it mostly works, but not 100%

-- Robert

Imprint | Privacy Policy