Delay in "Send Keyboard Shortcut"

Note:
Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.


Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).


Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)


Device information:

  • Type of Mac: MacBook Pro, Apple M2 Pro
  • macOS version: Version 14.4.1 (23E224)
  • BetterTouchTool version: btt4.539-45390 / btt4.537-45370

Additional information (e.g. crash logs, related issues, etc.):
There is a noticeable delay introduced in the latest version.
I'm using BTT as kinda of VIM anywehre, so my right command + k would be "up". updating to the latest i've noticed the delay, and installing btt4.536-45360 manually solved it for me.

I'm experiencing the same issue. Is there an easy way to roll back an update?

Here is the release page
https://folivora.ai/releases/

I just checked, but there have been really no keyboard related changes between : btt4.539-45390 and btt4.537-45370 (and barely any changes at all). Maybe something was just slowing down BTT a bit? If it happens again, please check whether the BTT process (or any other) is maybe using a lot of CPU.

I was just about to raise a bug report for this as well. I am also on :Sonoma 14.4.1 Apple M2 Pro. BTT version 4.526.

The Helper tool has been installed and config settings report that it's running as highest priority.

I'm using a Magic Trackpad v2 for gestures. Gestures don't appear to be picked up half the time and now only occasionally works. Once it detects the gestures and if you keep going, then it works fine. Eventually it starts to lag/delay/ignore again.

In this example here I am trying to get my browser window to go fullscreen mode, via CMD + two finger swipe up. You can see as it appears to be dragging the browser content window

CleanShot 2024-05-20 at 09.22.45 4

I've updated to MacOs Version 14.5 (23F79), now the delay happens in all BTT versions so i've updated it to the latest 4.537. According to Activity Monitor, before using the keyboard shortcut I've defined, BTT takes 3 to 6 % CPU. When I trigger the shortcut, it could jump to around 30% and clicking twice could get all the way to 50%.

Strange symptoms...

sounds like your shortcut might be triggering something in BTT itself. If you go to Help -> Export Diagnostic Debug Information and send the result to me (andreas@folivora.ai) I can have a look

In general shortcut sending still works fine on 14.5

Still on MacOs 14.4.1, installing btt4.536-45360 did not fix it for me.

I have some strange behaviors with BTT and my settings, lucky I back up the settings daily. because of it, after i've deleted my default profile and reimported it the lag is gone! so that's a win.