Delay in Copy Pasting

Describe the bug
When BTT is on, I have to wait an extra .5 seconds for the computer to register CMD+C and CMD+V, such that I often end up typing c or v instead of successfully copying/pasting said text. When BTT app is closed, functionality is normal. What settings might I have activated that might be making "it wait" if you will?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Keyboard.

Device information:

  • Type of Mac: Macbook Pro 2016
  • macOS version: Mojave 10.14.4
  • BetterTouchTool version: 2.813

Do you have the BTT clipboard manager enabled? Some apps don't like that, but you can disable it only for these specific apps

Hey Andreas,

No, I'm not using the BTT clipboard manager actually (it would be on if I were using a 'Show Clipboard/Pasteboard History' trigger right? I'm not currently doing that). Anything else it could be? Thank you for all your wonderful work!

Mh apart from that I haven't heard about any copy paste delays. Do you have any other keyboard/mouse tools installed that may conflict with BTT?

Hey Andreas,

I do not. I'm starting to suspect the delay might have something to do with the computer "waiting" to update the touch bar while Command is held. I have an app switcher with "Only show when modifiers pressed :CMD" is active globally on my current preset, could the system be waiting to update the touch bar with new buttons before it will process the CMD+C?

I'm pretty sure that's not it. Many people have this setup.

Maybe go to Help => "Export Diagnostic Debug Information to Desktop" and send that data to, then I can check what's wrong.
(Or in the old UI, open the about tab => Export Debug Information)

I saw this option in the latest version (Options>Advanced Settings>General), installed the Process Priority Helper Tool, and it's resolved my copy paste issues!! Thank you Andreas, you saint!

Hello all,

Unfortunately, I'd thought the Process Priority Helper Tool had resolved it. The problem came back again sadly. I disabled all modifiers in my preset, (CMD, Alt/Opt, Ctrl, etc) and I no longer have this lag in copy pasting. Luckily I didn't have much there that I'll be missing anyway. For what it's worth, on holding CMD I had a Dock Applet the appear to the full extent of the touch bar, so perhaps this was too CPU intensive for my laptop.