DD-MMM-YYYY custom date format getting unexpected behavior?

Describe the bug
Not 100% sure if it's a bug or a user error, but I tried to create a Touch Bar shortcut to insert the current date (pasting) in a custom date format. What I entered was:

(BTT)@dateformat:DD-MMM-YYYY

Expected: insert date such as 19-Feb-2019

Actual result: inserts above date as 46-Feb-2019

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Touch Bar. The command is running fine. Just the expected result isn't quite right.
Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro with Touch Bar
  • macOS version: 10.13.6
  • BetterTouchTool version: 2.697

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

have a look here: https://nsdateformatter.com/

Using capital D will give you the day of the year.