Dark mode toggle not working in Mojave

I assigned "Toggle Dark Mode" option to various trackpad gestures as well tried to drop this on the touchbar button. Neither of them worked. I have ensured that the BTT has privileges as in Security and Privacy of System Settings.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Trackpad, Touch Bar,

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 15" MacBook Pro 2017 with TouchBar
  • macOS version: 10.14
  • BetterTouchTool version: 2.650

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

It's working fine here. Maybe you didn't allow BTT to control via Apple Events?

Mojave asks every time a new app is being controlled:

Thanks for the instant response. I was able to figure that I missed this configuration. Can you let me know what kind of data is being used here as the Apple warning says "The app can have access to Documents and Data in those apps "

No data is being used for this. (Only the dark-mode state)