'D' Key Stops Working

My "d" key randomly stops working. In order to make my D key functional, I have to quit (not simply disable) BTT. Without fail, after quitting BTT the key becomes functional again and will continue working once BTT is restarted (until the bug happens again).

  • I have not been able to correlate the bug with another specific app being open
  • I have tried to check the preferences and keyboard shortcuts assigned to other open apps when it happens and have not found any that utilize the D key
  • I have checked in sys. pref. > keyboard > services / app shortcuts and have not found D utilized with either of these
  • I have checked all of my BTT shortcuts and none of them involve the D key.
  • I have consistently installed alpha updates
  • I have tried a system restart
  • Type of Mac: 2020 MBP, 13 in, 4TBs
  • macOS version: 12.3.1
  • BetterTouchTool version: 3.765

Is there anything I can do to troubleshoot further are there any fixes that I might be able to try?

What would be the best way to get some help or suggestions on fixes? Should I just reinstall the app? If I do this and import my saved settings, etc is there a good chance that it might bring the issue back?

Interesting. This is detective work. But not so funny for you. You've already done some systematic research.

"My "d" key randomly stops working". What does that mean exactly? You press the key and nothing happens?

Can you exclude a mechanical problem with the key? Does the same happen with another keyboard?

Have you checked the mac accessibility?

Does the key always work when BTT is not running? If BTT is not running for a day or more, does the key never fail?

1 Like

unfortunately this is hard to debug, I haven’t heard of anything similar, thus it’s probably something specific to your setup (which would probably return when importing the same preset again)

You are sure none of your BTT keyboard shortcuts involves a d key?

Any pattern when this happens?

Hi Frank, thanks for the response.

Correct, when this happens and I press the D key, simply nothing happens. I have not done any troubleshooting with another keyboard, but, ever since I noticed a correlation with BTT, every time the key stops working it will begin working again about 3 seconds after quitting BTT. This is the case every time & there has not been a single time where quitting BTT has failed to fix the problem. I can only conclude that this is causation and not mere correlation.

What would I check in Mac accessibility? (I currently have sticky and slow keys, both, disabled)

I haven't been brave enough to venture going that long without BTT. I can attempt to do so and report back.

Thanks, again, for the help and questions, Frank.

I don't know if I can be of much help to you....

Have you tried to simulate the "d" in BTT? Shortcut "d" = "d" plus "prevent recursive triggers" or have the "d" inserted by typing or cmd+v?

Thanks, for the response, Andreas.
I have looked back through my shortcuts and cannot find any involving the D key. I do use some predefined features like the app switcher and various commands so there might be a D key baked in one of those (though, this would lead me to believe that it would be a more widespread issue).

I have not been able to find any patterns apart from the very obvious ones—it is not happening with any other key, happens in various apps, and takes place throughout the course of typing emails, papers, etc. (so, not directly after using a BTT shortcut), and is fixed by closing BTT. Is there anything that you would say to pay particular attention to when trying to find any pattern?

Thanks again for the help.

Before I figured out that quitting BTT was the fix I would copy and paste another d to get to a stopping point before restarting my machine, so I know that this is a possibility.

I have not tried the former workaround, but appreciate the suggestion.

Probably pointless, but did you also check the key sequence, not only the shortcuts?

Can you define/point me to the "key sequence"? What I have check thus far is the trigger keys and I have looked through any keys that may be involved in whatever processes the trigger keys 'do.' Thanks for the time and thought, Frank.

You can go to help => export diagnostic debug information and send the results to andreas@folivora.ai (best do this right after you encounter the issue). Maybe I can find something in the logs.

Oh, wonderful! Will do, Andreas.

Like I said before, it happens quite randomly, so next time it happens I will try this. Thanks again.