Custom Window Snapping on Window Switcher

Thank you for offering the Window Switcher function. I find it extremely useful comparing to the standard cmd-tab function.
May I ask if it is possible to customise those nine standard window positions, or to change some of those nine positions to other snapping positions such as 1/3 left, center, and right vertical window?

Thank you in advance.

I hope someone will read this and help, at least a yes/no answers? Thank you very much

currently that's not possible, maybe in a future release!

Thank you very much for considering the additional feature!

If you use the keyboard, you can use your own shortcuts for your preferred window positions with the "Advanced Conditions".

With a German os the name of the window switcher seems to be "BetterTouchTool Ohne Titel".

So if the Window Switcher window is open, you can type for example "r" to trigger this macro.

And the window selected in the Window Switcher will move to the right third of the screen. This may not be very elegant, but it works. :slightly_smiling_face:

Thank you very much for the idea!

I hope I’m understanding the idea correctly:
(1) I first create a “named trigger”, say “r” for snapping the window to right third of the screen.
(2) I set up the “Advanced condition” for the named trigger “r”, only enable the trigger when the visible_widoiw_list is the Window Switcher.

You do not need a named trigger. :slightly_smiling_face:

The macro below moves the window selected in the window switcher to the right if you type "r" while the switcher is open. (Check in the "Visible Windows Viewer" what the window is called exactly).


Then you still need the "counterpart" to the macro above. So, type "r" if the window switcher is not visible. It should be enough to replace "All" with "None" in the Advanced Conditions. And don't forget to activate "prevent recursive trigger".

Thank you very much for the explanation. It almost works. I use "contains" as the condition as the full name of the Window Switch in UK English is "BetterTouchTool - Untitled - 3".

The problem is, after I enable "r" as the shortcut, the keyboard won't let me type the letter "r" anymore in everywhere.

Thanks again.

Yes, that's why you need to set this up additionally :slightly_smiling_face:

Done! Thank you very much! :pray: :raised_back_of_hand: :raised_back_of_hand:

1 Like