Crazy - Stuck Trigger Activates Even on Fully Empty (Solo) Preset

Describe the bug

Trying to put it as simply as possible, I have a mouse with multiple buttons, and the way I have managed to get the extra buttons to be recognized by BTT is to map them as keyboard shortcuts inside the Mouse's Native Software, and then to create actions in BTT in the Keyboard section, using those shortcuts as triggers. AND THIS WORKS BEAUTIFULLY.

OK, with that out of the way, here's the crazy part - there is one button that I have noticed that seems to have gotten "Stuck" with it's configuration inside BTT. That is:

  • Changing the actions does not actually change them. It will execute the original action I configured long ago.
  • Disabling the trigger has no effect. BTT still executes the actions.
  • The only way to stop the trigger is to delete it entirely. Then it will cease to work, but get this... if I recreate the trigger and don't assign any actions to it, it behaves as before!

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Logitech G604

I can provide a video later if desired.

Device information:

  • Type of Mac: Macbook Pro 16 2021 M1 Max 32GB
  • macOS version: Ventura 13.1
  • BetterTouchTool version: 3.952

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I tried to create a new preset, and disable the other preset entirely... and the trigger still activates! Even with a fully empty preset!

Also, I have actually noticed with other actions that disabling them doesn't disable them. Thus I've been forced to fully delete triggers to get them to stop working in many cases. I don't believe this to always be the case though. It is thus possible that there are other actions that may also be "Stuck" though I haven't noticed it yet.

could you check in live view whether it recognizes any action? (It will only show the text for mouse triggers)

Yes, I forgot to mention. I had checked, and it does not recognize it.

that’s very weird. Are you sure this is configured in BTT? So if you quit BTT the action won’t be executed?

OK... you got me this time! I quit BTT and the behaviour remained, which made it obvious it was something else. And further investigation led me to find out the remap was configured through another app that I had forgotten about :sweat_smile:

I guess what made me confused is that deleting the trigger in BTT actually made it stop working for some reason! I did test this multiple times and this was the behaviour.

But, alas, the mystery is solved!

Just FYI on the topic of triggers not effectively disabling, what I noticed just now is that disabling a trigger that belongs to a conditional group will prevent other triggers from other apps that have the same trigger from executing, unless:

  • The trigger in the conditional group is placed inside a folder and the folder is also disabled.
  • The trigger is deleted. After deletion, if you hit CMD+Z to restore it, it will still not block other triggers from taking over / runnning correctly, unless BTT is restarted, at which point it will resume preventing things from running.

I'm not sure if this is the intended behaviour. I would imagine not. If you're interested we can investigate this further, or I can open up a new topic. Let me know :slight_smile:

Thanks for now!

Disabling is currently not implemented for all trigger types - but I'm working to fix that soon.

1 Like