Crashes in Custom Move/Resize window Configuration menu (v 3.389)

Describe the bug

BTT crashes when modifying fields in the window resize configure menu.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

internal keyboard

Device information:

  • Type of Mac: 2016 Macbook Pro w/ touchbar.
  • macOS version: 10.14.6
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    3.389

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):


Screenshot of menu attached. Crashes happen frequently when modifying fields in this window.

I'm a huge fan of BTT and have had licenses for many years now, but this is the first time I've ever reported a bug. I love this app and how it has evolved overtime... it has increased my productivity an immeasurable amount.

While we looking at Custom Move/Resize Window, I've noticed the following:

  • I can modify the fields, however clicking backspace results in a crash
  • When "set the position based on the" is set to "Top left corner of the screen", the "New Y" setting is ignored and the window is always pegged to the top of the screen (or bottom of menu bar), both in Absolute and Relative settings.

Device information:

  • Type of Mac: 2016 Macbook Pro w/ touchbar.
  • macOS version: 10.15.5
  • BetterTouchTool version: 3.3.90

For me this happens every time when I try to change the new X value of "Change x origin to" after selecting that checkbox in the "Move / Resize" action.
I want to move an application to a specific position on the screen.
Running Catalina 10.15.5 on MacBook Pro 2018.
Can this be fixed?

For X the percentage setting worked just now, the Y percentage worked for a bit as well but crashed just now.
Happens with latest stable and latest alfa version.

Process: BetterTouchTool [38401]
Path: /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool
Identifier: com.hegenberg.BetterTouchTool
Version: 3.392 (1616)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: BetterTouchTool [38401]
User ID: 501

Date/Time: 2020-07-11 09:04:08.007 +0200
OS Version: Mac OS X 10.15.5 (19F101)
Report Version: 12
Bridge OS Version: 4.5 (17P5300)

Time Awake Since Boot: 100000 seconds
Time Since Wake: 13000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

I'm having the same issue when trying to update the y-offset

Thanks for reporting, should be fixed in the latest alpha version!

1 Like
Imprint | Privacy Policy