Crash when opening app

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

I can't open the app ever since I updated to macOS Catalina. When I open the app, the app opens for less than half a second, then crashes and I get a problem report screen that says "BetterTouchTool quit unexpectedly." as well as a 5 page jumble of words and script. I have restarted my Mac multiple times and turned the accessibility on and back off (that was one of the suggestions) and nothing seems to fix it. I made a keyboard shortcut before I updated to Catalina that toggles on and off the BTT TouchBar and that still works as well as everything in the Touch Bar that I created from BTT. All my other trackpad gesture triggers still work as well but I just can't open the application.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2018 MacBook Pro 13in
  • macOS version: macOS Catalina 10.15
  • BetterTouchTool version: (please post the exact version - not just "the latest one") I don't know because I can't open the app but I'm pretty sure I had the latest version before I updated to Catalina (I updated the day macOS Catalina came out).

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

crashes after macos updates can usually be fixed by completely removing it from the accessibility settings, then readding it again. Disabling if not enough unfortunately.

Can also be done with this terminal command (only run if BTT is quit)

tccutil reset All com.hegenberg.BetterTouchTool

As I said in my original topic, I have tried removing BTT from Accessibility and enabling it again with no luck. I discovered today that I can open BTT from the Menu Bar, only if I click "Old Configuration UI". If I open the app from Finder or if I click the normal "Configuration", the app crashes immediately. From the Menu Bar I was able to find that the software wasn't current so I updated the software (I am now Version 3.207). I also updated to macOS Catalina 10.15.1 today. None of these fixed the issue. I was then toying around with the settings in the old configuration and I found out that by deleting my keyboard shortcut that I had enabled to open the BTT app, this fixed the entire issue. I tried adding the shortcut back but then I couldn't open the app again, so I deleted the shortcut again. I have no why this was a problem but I'm glad I fixed it. It would still be nice to have that keyboard shortcut to open the app though. Any suggestions would be greatly appreciated. Thanks!

Imprint | Privacy Policy