CPU Load on DOCK goes to 70% when running BTT

When running BTT for a while, my CPU's start going nuts.. When I look it shows the DOCK is running extremely high. But if I shut down BTT CPU goes back to normal.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

If I kill BTT and restart it.. things go back to normal...

Device Information:
MBP 13inch 2018 - Four Thuderbolt 3 ports
Processor: 2.7ghz Quad CoreCore i7
Intel Iris Plu Graphics 16MB

macOS Version Catalina 10.15.3
BTT version: 3.346 (1554)

mh are you using the Dock widget in BTT?

yes, I am using the GC-BTT, and have enabled the Command Menu

I have turned it off and will monitor over the next few days

Great! I'll also check whether there is an issue.