CPU @ 100% version 4.460 SetApp, Sonoma 14.4.1, M1

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug

SetApp sits at 100% CPU, also after a restart of both application and computer.

It's causing missing keyboard inputs and is obviously screwing with my computer.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

All; I'm mostly affected by the keyboard but it's an overall application problem.


Uploading: Screenshot 2024-04-17 at 12.41.41.png…

Device information:

  • Type of Mac: 14" 2021 MBP M1 Max
  • macOS version: 14.4.1
  • BetterTouchTool version: 4.460 SetApp

Additional information (e.g. crash logs, related issues, etc.):

You mean BTT or Setapp at 100%? (if Setapp, you'd need to contact their support)

BTT; the reference to SetApp was only meant to indicate that's the version I have installed and I got things mixed op typing, sorry.

do you maybe have the experimental dropbox / icloud sync enabled in the settings? If so, try to disable that.

If not, is there anything that you notice or so before it goes to 100%? It could e.g. be a keyboard shortcut that keeps triggering itself

I did I have it on (for iCloud), and tried switching it off. That did reduce CPU usage.

Previously it looked like it was at 100% "all the time," in particular for a while (1-2 minutes) after startup. Restarting BTT now without the sync enabled it doesn't go to 100% on startup.

I also noticed fileproviderd previously being around 100%, and this too has returned to normal.