Copy, Cut, Paste as Predefined Actions

Could you include Copy, Cut, Paste, and Save as Predefined Actions instead of having to make a Custom Keyboard Shortcut for them. The modifier keys don't work properly in some apps so this would make it easier to use those functions.

you can use the "trigger menubar menu item" action if for some reason keyboard shortcuts do not work for the app

Unfortunately I'm trying to use this with Blender which doesn't use the standard Mac user interface. It's main menubar at the top of the monitor contains only the Apple, Blender, and Window tabs which don't do anything useful. There's a second level menubar at the top of the application window which contains the File, Edit, etc tabs. And to make matters worse, there's a third level menubar below that, that's dependent on what mode you're in -- Edit Mode vs Object Mode etc. It's at that level that contains the Copy and Paste commands. I have not been able to figure out a way to get there using "trigger menubar menu item".

I've tried using "trigger context menu item" however when I use that, the context menu pops up but does not execute the command (Copy Objects or Paste Objects) I've typed in.

What should I try to get this to work? Thanks

unfortunately this is hard ;-(

I'm not aware of any way to trigger these actions which is not based on sending shortcuts or menubar commands.

Does Blender not recognize any keyboard commands you send to it?

Blender doesn't recognize the modifier keys sent from BTT. It will execute those keys as if the modifier wasn't pressed. However, I have some partial success.

Within Blender I set Copy Objects to J instead of Cmd-C and Paste Objects to P instead of Cmd-V. Now pressing J and P on the keyboard will copy and paste. Within BTT I set 4-finger swipe left to J and 4-finger swipe right to P. The swipe left will copy but the swipe right will not paste (even though pressing P will paste after swiping left).

Another weird thing that happens is that in order to execute Cut, I set 3-finger swipe up to J then Attach Additional Action to Forward Delete (copy then delete). However, when I execute the swipe up it deletes the object but does not copy it.

Could you check whether BTT's "Shortcut Sending Compatibility Mode" helps?

After checking Shortcut Sending Compatibility Mode the Cut function now works properly, but Paste still does not. I've tried assigning Paste to several different keys, and each time, pressing the key on the keyboard will paste but the trackpad gesture assigned to that key will not.

weird, I think that should be a bug report for blender then as BTT definitely generates valid keyboard commands :-/

If I get some time I'll download blender and see whether there is any workaround.