Context Menu (NEW) Actions Not Working

Describe the bug
I've done a clean install of the Mac and have an issue with Actions not working correctly when inside a new context menu. They are very simple actions (launch an app, send a keyboard shortcut etc) and work when not placed in a context menu, but when placed in one instead of triggering correctly, they open the recent files section in Finder. Actions for the shortcuts app however seem to work fine. I've tried rebuilding context menus from scratch with the same result.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Using the mouse

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: M1 Studio Ultra
  • macOS version: 14.3.1
  • BetterTouchTool version: 4.401 (Setapp)

Unfortunately I can't reproduce this yet. Could you copy the context menu and paste it here?

thanks, i couldnt fit it in the forum post, so ive attached it as a text file. it seems to have generated a lot of erroenous data. (231.5 KB)

It seems to work fine here, I can't find any obvious erroneous data in there.
This configuration is not officially supported but also seems to work ok here:

Is there a specific trigger that doesn't work on your machine?