Configure HyperKey

Currently Hyper Key maps the functionality of ⇧ + ^ + ⌥ + ⌘

I would like the option to remove the ⇧ key from the combination so that I could use "Caps Lock" + ⇧ for shortcuts.

Do you just want to change the caps lock key to an "additional modifier" (which can be used with or without ⇧), or do you explicitly need caps lock to be ^ + ⌥ + ⌘?

I explicitly need caps lock to be ^ + ⌥ + ⌘

I agree hyper key customisation would be really useful.

In the meantime, Karabiner Elements can do this via its Complex Modifications. You can completely configure this. What you'd do is make two assignments:

  • Shift + Capslock = Shift + Control + Alt + Command
  • Capslock = Control + Alt + Command

I just made a rule that does that in Karabiner, so if you decide to install Karabiner you will be able to install the modification by going to this link and clicking the INSTALL! button on the right. (Don't edit it in the left pane as I had to make some manual text edits to get it to work - the JSON editor seems to have some bugs.)

That will open Karabiner, in which you can choose to Import, then Enable All the modifications, resulting in this view in Karabiner's UI:

And that appears to be working fine for me.

If you do that, of course remember to disable BTT's hyperkey modification (unless/until we get the option to configure it in BTT instead.)

Now I need to see if I can learn two hyperkeys! :slight_smile:

I did try Karabiner but it seemed to mess with my keyboard (Logitech MX Keys) backlighting and also didn't map some of the keys properly.

I have found a free tool hyperkey in the short term that does the job with some basic configuration:

The only issue is it only works with BTT using the old shortcut implementation.

Ideally it would make sense to have it all in BTT.

I don't use a Logitech MX but having briefly checked the Karabiner Elements issues page, there was a post on Jan 10 where some people reported some of the built-in keys not working with Karabiner, and this was posted:

No mention of backlight issues I could see but I'd certainly try that advice to see if it helps with all the issues.

Thanks, tried again with the update but still no luck.

Hyperkey app seems to be working well for now although it's just a shame I have to run a separate app :stuck_out_tongue_winking_eye:

If you want to do it with BTT, what comes closest to what you want is "Caps Lock" + fn (instead of "Caps Lock" + ⇧)