Compact AirPods widget with User-Friendly Setup

Still the same result. The name is replaced after two connect-disconnect actions by my AirPods' name. I don't get this honestly…

Expected behaviour:

[condition: correct behaviour]

Variable does not exist: First-time setup window pops up
Variable exists, is empty: "could not find" window
Variable exists, incorrect name: "could not find" window
Variable exists, correct name: connects airpods

(for recent reply);
Try holding the widget, and see what name is inside the brackets

edit: :thinking: I tried this myself. BTT seems to regenerate the variable if you delete it form the plist file

Ok, don't ask me what happened. But after

  • Deleting again the whole line from the Xcode file
  • Restarting BTT
  • Importing your whole preset once again
  • Setting the action script you posted above
  • Making it the Master preset
  • Restarting BTT

Everything went as expected. BTT asked for the AirPods name, everything is fine with this and works as it should!

Could you upload an exported preset here to make sure we aren't missing any of your changes?

Also do you think that it's stable enough for a beta test?

Sure for both of your questions!
Compact AirPods Widget - d1.2.bttpreset (70.0 KB)

1 Like

Also, I run this widget integrated to my personal preset, where it runs without any troubles too.

I should have some time today to test this! Just keep buggering me lol.


Hm. Recently, I discovered a bug where the Widget shows the alternate icon although the AirPods are not connected as soon as any other Bluetooth device is connected. It's annoying. Anyone else who tested the widget for now had this trouble?

@GoldenChaos Help with the regex please :sweat_smile: I don't really know how to regex

I probably didn't set this in a 'good practice' way

@GoldenChaos, @Caliguvara

Edited post as beta test. Hopefully we don't break anyone's BTT.

Sweet. Working on a new portion of the settings menu to allows users to configure custom bluetooth names to search for, I expect to be a modified version of this. Might start today, it's my next major feature :smiley:

1 Like



Does this work though? I’m not sure if it’s stable as of now!!

You should thoroughly test it first. Get back to me with your results so I can post them (or you can if you want since you have mod)

1 Like

Status for now: works perfectly fine, just the icon that changes as soon as any other Bluetooth device (headphones, but also keyboard, mouse,…) is connected. Still not sure how to fix this though.

1 Like

will look into that. Thanks!

Is it running smooth though? it may be working but does it work with hickups?

Nothing that would have come to my consciousness :wink: Runs smooth, from inside groups, from outside groups, it's good for me :man_shrugging:t2:

1 Like

This seems to be the issue, and i have absolutely no idea how it works. Anyone Help?!

Any update on this? I tested on d1.2 it seems to can't find my AirPods.

I can't test for bugs myself as I don't have AirPods. Make sure the name you put in matches your AirPods name exactly though!

Tried to hold it? In order to reinitialise their name?

(edit: I was just about to launch my C3 with this widget in it)

I have checked many times and it still doesn't work, I have no idea why ( ; - ; ) It showed success icon in a spit of second and then went back to grey out icon.

edit: I added photo

Imprint | Privacy Policy