Clipboard manager slow to copy from MS office applications

#1

Describe the bug
When copying from MS office applications (excel, word, powerpoint) I often/usually get a spinning beachball for a few seconds before I can paste/do anything in the app. when disabling clipboard manager in BTT the problem goes away so it seems to be an issue with BTT.

The problem is particularly noticeable in excel.

Device information:

  • Type of Mac: 2016 15" MBP
  • macOS version: 10.14.2
  • BetterTouchTool version: 2.717 | 1027
0 Likes

#2

That's because BTT needs to access the clipboard data to save it. The office apps may take a while to produce this data when it is requested.

You can however disable the clipboard manager selectively for specific apps that respond too slowly.

0 Likes

#3

New to BTT thanks to Automator podcast.. I wonder how I can disable Clipboard Manager entirely, if not, how to disable per app? I don't see it in the drop down menu bar icon nor in the BTT pref pane:
image

0 Likes

#4

You can disable it using the BTT menubar:

If you want to disable it completely, just remove any clipboard manager action from BTT, then restart BTT.

0 Likes

#5

I don’t see the option to disable Clipboard Manager in the menu bar (and yeah, I noticed you shared the same tips in another thread when I searched). Is it because I don’t have any actions related to Clipboard and therefore Clipboard is not active?

0 Likes

#6

Yes, if it's not active then that won't be shown.

1 Like

#7

I had the same problem. It took me months to finally erupt and google a solution and found it is because of btt...
anyway the above solution ways for me. thanks
and just one final thought:
i have pastebot as clip board manager and pastebot works well with excel.
this seems to be the other side of "That's because BTT needs to access the clipboard data to save it. The office apps may take a while to produce this data when it is requested."

0 Likes

#8

"i have pastebot as clip board manager and pastebot works well with excel."
--> i was wrong. pastebot has the same problem. I got the wrong idea because i forgot about the fact that i had already excluded excel in pastebot preference...

0 Likes