Clipboard Manager Only Displays Last 10 Items in Touch Bar

Describe the bug
BTT's clipboard manager only displays the most recent 10 items in the touch bar that were copied. I can see in BTT's clipboard history menu that the full history is getting saved in the DB. But, only 10 of them are getting displayed on the touch bar.

Affected input device:
Touch bar

Screenshots


Device information:

  • Type of Mac: MBP 15 inch, 2018
  • macOS version: Monterey 12.2
  • BetterTouchTool version: 3.743

Any word on this? Has anyone tried reproducing?

the clipboard manager widget for the touchbar has a setting to set the number of items to show. However it shouldn’t be too high for performance reasons

Thanks for your reply. Maybe I am missing something but I can only find a setting to adjust the number of favorite items to show. Changing it still only shows the 10 most recent items on the touch bar plus however many favorites I have / choose to display. But it's more recent items that aren't favorites which I'd like to see. I work a lot with text and find easy access to the full history on the touch bar very useful.

I want to say I noticed the change in behavior from being able to see the full clipboard history in the touch bar to just the 10 most recent items at or around the version 3.740 update.

@Andreas_Hegenberg As I mentioned above, I only see a setting in the touchbar's clipboard manager widget to adjust the number of favorites to show.


Unless I'm missing something, could you add a separate field to choose the number of recent items to show?

I have been having the same problem for some weeks, for me it only shows the last 4 items.

Hi @Andreas_Hegenberg, this is still an issue in 3.843. Is there any way you could get the clipboard manager to either show all of the clipboard items from history in the the actual touch bar (as in versions several releases back), or have a setting to show X number of items (not favorites)?

Hey, for me removing the widget and creating a new one fixed the problem. in case you havent tried that yet.