Check for update, auto-update and launch on startup not working

#1

Describe the bug
Clicking on the "Check for updates" button in Advanced Settings yields an error:

BetterTouchTool can’t be updated when it’s running from a read-only volume like a disk image or an optical drive. Move BetterTouchTool to Applications folder using Finder, relaunch it from there, and try again.

BTT is in the Applications folder, however.

Auto update also doesn't seem to work, I had to manually update to 2.530.

I've restarted BTT, also the whole machine.

This has always worked before, no idea why it doesn't now.

Device information:

  • Type of Mac: 2017 15" MBP
  • macOS version: 10.13.5
  • BetterTouchTool version: 2.530
0 Likes

#2

PS: I've also noticed BTT won't launch automatically at login anymore, even though that option is enabled. I have a feeling that's a related issue...

0 Likes

#3

BTT 2.503 also ignores the "enable automated update checking" setting (checks and nags anyway).

0 Likes

#4

Regarding the launch at login issue, I've noticed that Login Items in System Prefs is cluttered with useless BTT entries:

Deleting all of them and disabling, then re-enabling the "Launch on startup" option in BTT produces a seemingly valid entry in Login Items, but on login it still doesn't launch. However, disabling the option, removing all BTT entries from the list and adding the BTT app manually (via the "+" button) works without problems—just like manually launching the app does.

0 Likes

#5

I'm still having these issues with 2.645 on 10.13.6. A reply would be much appreciated.

0 Likes

#6

I am having this same issue. It started after I did a clean install of High Sierra and reinstalled BTT. Now I have to manually launch BTT every time I restart the computer. I was hoping to find a solution for it. I guess I could try removing and reinstalling it.

0 Likes

#7

Bump!!!
Hello! How come no response to this 2 months later?

I've deleted and reinstalled the latest veriosn since auto updates won't work. (gives me the "not in applications folder" error even though it is) So I have to delete and download manually.
No change in the failure to run or update.

0 Likes

#8

I think that's a bug in High Sierra. You may need to manually drag it into the Application folder so macOS gets the permissions right.

0 Likes

#9

I always drag apps manually to the /Applications folder (or, in many cases, a subfolder, though it doesn't seem to matter). The "... is not in the Applications folder" message appears anyway. Seen it with many apps (that's probably the bug you mean).

What do you mean by "permissions"? The file permissions are correct at 755, with ownership by the user and group "staff", just like all other non-App Store apps.

0 Likes

#10

weird! Are you using some third party file manager or Finder itself?

I didn't mean the normal file permission but these new automagically managed ones that get added when dragging apps via Finder to the Application folder and cause these error messages if something goes wrong. I thought they fixed that issue at some point though, but if you are on 10.13.6 that doesn't seem to be the case.

0 Likes

#11

I was just about to post that using Finder instead of Path Finder seems to have solved the issue. At least manual update checking is working again, I will report back in case auto-update or launch on startup should not be working as well.

I virtually never use Finder, been on Path Finder for 10 years probably, never had a problem like this before. (Those "Move to the Applications folder" messages, yes, but I too think those got cured somewhere along the way, the only one I was still seeing was the custom one in BTT's preference window.) Good to know Finder's now doing special things on simple operations like a file move...

PS: Not directly related, but I think the release notes are missing for the current version on the website. They stop at 2.717 and the latest download gave me 2.762.

0 Likes

#12

I was just about to file a bug report about something else but then I realized that my BTT is version 2.427 when the most recent one is 2.717. From this I can only deduce that automatic updates aren't working here either, and I'm on Yosemite! I want to update in case it fixes the actual bug I was having, but I was unable to find any info on which BTT versions are compatible with which OS versions. It would be great to have a little OS version compatibility mention right under the "download latest" button, or elsewhere easily discoverable. I rely on BTT so heavily that I would really like to know about compatibility instead of test, mess things up and regret!

0 Likes