[Catalina] BTT is stopping working after a while since the last update

yes, I have tried the latest (alpha) version of BetterTouchTool - the same behaviour.

Describe the bug
I have a few mouse swipe actions. It works for let's say 5 minutes after BTT starts but then a main focused window just folds to a very little in the left and it effectively means that BTT is down.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Magic mouse swipe actions including 1 finger scroll.

Device information:

System Version: macOS 10.15.7 (19H15)
Kernel Version: Darwin 19.6.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Model Name: MacBook Pro
Model Identifier: MacBookPro15,1
Processor Name: 6-Core Intel Core i7
Processor Speed: 2,2 GHz
Number of Processors: 1
Total Number of Cores: 6
L2 Cache (per Core): 256 KB
L3 Cache: 9 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Problem still persists.

Could you post a screenshot of your setup or go to Help => Export Diagnostic Debug Information and send it to andreas@folivora.ai?

I think haven't had similar reports but I'm also not sure whether I fully understand the issue yet.

Reverted back to 3.4045 and it worked fine again.

. Nonetheless I updated again to the latest version and sent diagnostics to your email.

Turns out this version doesn't work well too. Scroll gets buggy after a while and time to time skips actions

It seems that BTT getting stuck and when this happens nothing works pretty much. I just tried to check for updates and update window wasn't shown. I clicked "Restart BTT" from the menu and tried to check for updates again - it worked.

Also, I think it can be a problem with my particular mouse but I don't have any other to check. It would be great if BTT would give me some diagnostic to say is it bad or not.