Catalina 10.15.7 : not asking for Screen Recording (and maybe other) permissions, how to add?

Describe the bug
I just upgraded my Mac Pro to 10.15.7, from 10.14.6.

It seems BTT has not asked for the necessary security permissions for screen recording - or if it did ask, they didn't get added.

And now I can't find any way to get it to ask again.

I've rebooted multiple times, restarted BTT multiple times, tried taking a screenshot with BTT (it seems to work, but then the screenshot is just solid blue).

How can I get BTT to request all its permissions? Some other apps have a button to trigger the permissions request any time, given how crap macOS is at applying the permissions the first time it's asked to. But I couldn't find an option like this in BTT.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots

Device information:

  • Type of Mac: MacPro 6,1
  • macOS version: 10.15.7
  • BetterTouchTool version: 3.508

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

You can reset the state of BTT's screen recording permission memory using this terminal command:

defaults write com.hegenberg.BetterTouchTool BTTDidCheckScreenRecording YES

(while BTT is quit)

Thanks for the reply, Andreas.

I tried:
defaults write com.hegenberg.BetterTouchTool BTTDidCheckScreenRecording YES

and that did nothing that I could see.

So I tried:
defaults write com.hegenberg.BetterTouchTool BTTDidCheckScreenRecording NO

And that did have an effect - on next start of BTT, it seemed to be saying it was asking again for permission

However like before it did not actually ever ask for the permission

Ah sorry "defaults write com.hegenberg.BetterTouchTool BTTDidCheckScreenRecording NO" was correct :slight_smile:

Could be an issue with the TCC database then (the macOS database that handles these permissions).
Do other apps show up? (e.g. this terminal command should also trigger a permission request:

screencapture test.jpg

Ah, no that did not generate a request. And 'test.jpg' ended up being 100% blue, like the screenshots BTT is currently taking.

I do have one app on my Screen Recording permission list - Bartender 3 - but yes, it seems like nothing else is now able to add itself to this list?

I opened Console and searched for 'tcc' and then ran 'screencapture test.jpg' again. Here are the logs:

I notice in particular "Service kTCCServiceScreenCapture does not allow prompting; returning denied."

That sounds problematic?

I guess it's not a BTT problem at all, but if you happen to know what I could do to fix this, I'd be very grateful.

And thanks very much for the fast responses.

Unfortunately in many cases only resetting the TCC.db will help. This is a relatively complicated process that involves disabling SIP for a moment.

In a first step try this terminal command (quit BTT before running it):

sudo tccutil reset All

This will try to reset the whole TCC database - if it works you might get prompted for quite some permissions afterwards.
If not I'll look up the instructions on how to do the manual reset, I have them somewhere here on the forum.

1 Like

OK thank you, that did work - I now have BTT in Screen Recording.

That was quite a ride. I ran the command and it said "Success". Then suddenly I couldn't do anything. I could move my mouse cursor, but not click on anything, nor type anything! I could see the system was still working, because Activity Monitor was still active. But I couldn't interact at all.

I was able to SSH in from another macOS system and launch apps via the command line, but then I couldn't interact with them. In the end I had to trigger a reboot from the remote system, and when I was logged in again, I got the expected avalanche of permission requests, and I was able to use my trackpad and keyboard OK.

I guess it's because I have so many apps that need security permissions, including display-affecting apps like TotalSpaces 2, and keyboard-affecting apps like Karabiner Elements.

I really hate macOS permissions system! It's so badly implemented. I now totally expect it take two or three attempts before a certain app would have the permissions it needs. I wish we could just manually add apps to the Screen Recording list, and others like it, like we can with Accessibility.

Anyway, thanks very much for the help! All seems to be OK now.

Yes it's super annoying and also still so buggy. The freeze you describe is an issue that Apple knows about since at least 2 years...

1 Like
Imprint | Privacy Policy