Can't make presets inactive

I have made 2 different presets with different triggers to switch between. But all the triggers on both presets are always active, even when I deselect the 'active' button on one preset.

  • Type of Mac: Macbook Pro 15" mid 2014
  • macOS version: Mojave 10.14
  • BetterTouchTool version: 2.754

Are you sure you didn't accidentally put everything in one preset? The switching seems to work fine here.
You can see which preset something is in if you assign a color to the preset.

Hi! This is the way I have it set up. It doesn't matter if I tick the 'active'-box or not, all triggers are always active. They disappear from the list, as you can see, but they still work anyway.

Mhh if they are not visible they shouldn't be able to trigger. Are you sure there is no global trigger that does the same? Maybe try to assign a HUD overlay to the shortcut, to see whether it's really the one being triggered:

None of my global triggers use the same key sequenceI. tried the HUD overlay and it was the trigger not in the list that was being triggered. I did some more tests to troubleshoot. When I added a global trigger to one of the presets it worked fine turning it on and off. An app specific trigger to Finder works as well. But the app specific to 'Cubase' in the same preset doesn't turn off. I've tried different triggers and key sequences but nothing for this specific program (cubase) seem to work (or rather works all the time when it shouldn't)

I noticed it shows Cubase twice in your screenshot. Maybe you once added it via "Select from filesystem" and once via "select app from running apps". I'll check whether that could cause such an issue.

Hi! I don't think that's it. It's not the same program even though the logo looks the same, it's actually two different versions of cubase, an older and a newer. I have both installed on my computer. But I haven't assigned any triggers to the older version

Hi. Same problem here. Using version 3.097; Mojave.

My main preset is green, and I created another one with blue color. The blue shortcuts are supposed to stop working when I deactivate the preset, but they keep working.


Same here - commands are definitely in diffferent Groups as shown by the Colours. Disabling the Preset Group does not deactivate them - just removes them from the BTT UI. Even Restarting BTT makes no difference

I did Copy the commands from an old Preset and paste them into a new Preset Group - i suppose its possible that has something to do with it?

I'm having this same issue with lightroom classic. I have a desktop monitor preset and a laptop preset, each has specific mouse coordinates bound to keys.

Regardless of which preset is currently loaded as master, when I hit my key I get a popup featuring both sets of mouse coordinates and I have to choose which set. The other preset is never checked and the other set of mouse coordinates is never visible when in BTT menu looking at the triggers for lightroom classic under one preset or the other.

My use case is that I want my keybinds to send the mouse cursor to specific locations in Lightroom, but those locations change when I'm on my laptop vs when I'm plugged into my desktop monitor. If anyone knows a fix or a workaround for this issue, I'd love to hear it!