Can't Make Customized TouchBar Display Anymore

Describe the bug
A few weeks ago on one of my machines stopped displaying my TouchBar customizations, though I don't think it was based on any updates. I've included a couple of screenshots of my current settings, they match the options on another computer where it's currently working, though I tried a few other options as well if you have guidance on how to get it working again.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

Screenshots


Device information:

  • Type of Mac:
    MacBook Pro (2018)

  • macOS version:
    10.14.6 (and was happening on 10.14.5)

  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    3.170

Is it maybe just hidden? Does the BTT menubar icon menu show "Your Touch Bar is currently hidden" when you click on the BTT menubar icon?

Yep, that was it. Thank you very much, I really missed the TouchBar integration! I had the menu bar icon disabled and didn't know that was an option. :sob:

Kind of curious, how does it get into a state where it's hidden? And might it be worth adding that option into the new TouchBar settings panel to make it more apparent when that happens?

My touchbar was displaying fine in the standalone BTT app. But, after I switched to using the SetApp version of BTT, the touchbar is not shown any more. The menu does not show any option for "Your TouchBar is currently hidden." Any ideas?

Setapp version uses a different preferences file, thus previous settings will not be used.
Make sure Touch Bar support is still enabled and configured correctly:

Yes, my BTT settings for the touchbar is identical to the image in your post.

I may have misunderstood. Does your BTT show "Your Touch Bar is currently hidden" ? Or not?

In general it's a good idea to define a keyboard shortcut in BTT and assign the action "Toggle BetterTouchTool Touch Bar". This allows to hide/show your custom Touch Bar at any time.

No, BTT does not show that my touch bar is hidden. And, I did set up a keyboard shortcut to toggle the BTT touch bar. When I try the shortcut, I get the error beep like it is unknown.

Could you attach an export of your current setup? (top right Preset button => Export Highlighted)

Default.bttpreset (85.3 KB)

That seems to work fine here.

However your keyboard shortcut is added not to the global section but to a conditional activation group "temp" which doesn't have conditions defined. If you move it to your global / all apps section it should work:

I moved it to the all apps. I still get the error beep when trying to toggle the touchbar. Any other ideas?

Is there a setting on the Mac that needs to be updated to make sure that BTT has OS privileges to display touchbar? I don't know what I need to do to get this to work. the touchbar was fine with the standalone BTT app, but I can't seem to get it to work with the SetApp version

the setapp version is exactly the same thus it can only be a settings issue.

The only required system setting is System Preferences -> Keyboard -> Touchbar shows App Controls.

Maybe check whether that is still set. Otherwise I'd try to completely reset BTT by deleting

~/Library/Application Support/BetterTouchTool

and

~/Library/Preferences/com.hegenberg.bettertiuchtool-setapp.plist

Touchbar is set to show App Controls. If I completely reset BTT by deleting what you identified, do I lose everything that I configured?

forget this. I got it to work. I just cycled App Controls to something else and then back. thanks

1 Like

damn that's annoying! Sorry for the issue! Unfortunately this is handled by the system and I haven't found a good way to check whether this is set correctly :frowning:

Imprint | Privacy Policy