Can't get any "now playing" widgets to work on Mojave

Describe the bug
I have tried using presets, and using the AppleScript code to create from scratch but cannot get iTunes now playing to work at all. When I click "run script" I get an AppleScript error that says "Not authorised to send Apple events to iTunes"

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MBP 15" 2018 i7
  • macOS version: 10.14 dev beta 6
  • BetterTouchTool version: 2.543 (875)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

mhm, sounds like a mojave bug.
Instead of the message you get, there should be a dialog asking you for permission.

Are you maybe using some special user with less rights?

Maybe check whether you can set anything in System Preferences --> Security and Privacy -> Privacy -> Automation

Im on an admin account.

In the Privacy > Automation settings, BTT has permission to control System Preferences but nothing else, and I cant find a way to add any other permissions. I've done a decent amount of searching and can't find anybody else with this issue in Mojave sadly.

Unfortunately it's a Mojave bug. I have also encountered it already but have no idea how it got resolved.

You can try to reset all permissions with this terminal command, but I don't think it helped me :frowning:

tccutil reset AppleEvents

I think I have figured out what's causing this. I have adapted BTT, would be great if you could test the latest alpha.

Yes! Confirmed fixed, thanks so much man!