Can't edit BetterTouchTool or use shortcuts (text is purple)

Describe the bug
I am unable to edit or add shortcuts in BetterTouchTool or to use existing shortcuts. Text for preexisting gestures appear in purple and cannot be edited. When making changes and closing the main BetterTouchTool window, I get the alert "The file couldn't be saved because you don't have permission." Using preexisting gestures do not trigger the specified actions.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro 13" w/ Touch Bar (2018) running macOS Mojave (10.14.2)

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 13" with Touch Bar (2018)
  • macOS version: Mojave (10.14.2)
  • BetterTouchTool version: 2.636

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Looks like you don't have a master preset selected for some reason (should not be possible). You can try to set one by clicking Manage Presets.
However the file permission error seems to be a separate issue. Did you restore BTT from some backup that might have messed up the write permissions?

Hi Andreas — Indeed, I restored from a Time Machine backup after switching to a new machine. I ultimately did the lazy thing and uninstalled BetterTouchTool completely and reinstalled it and re-added my license, and that appears to have solved my issue, as I didn't have too many shortcuts to re-implement; but unfortunately that means I didn't really learn what caused this issue in the first place.

1 Like