Cannot 'send keyboard shortcut'

** Summary **
I want to trigger an application which only has limited keyboard shortcut activation customisation, and is activated with Cmd-Alt-X. I tried using the BTT 'send keyboard shortcut', but this simply does nothing. I have also tried using the Cmd-down, Alt-down, 'x', Alt-up, Cmd-up to simulate the desired key combination, but all I get is a situation where macOS behaves as if it has a stuck Command key (a command key constantly pressed down). This makes it impossible to use the system, until I quit BTT, which releases the Command key.

Device information:

  • Intel MBP, i9
  • macOS 12.6.2
  • BetterTouchTool version: 4.062

** Workarounds **
The only way I could get the desired result was using Keyboard Maestro, where the desired simulated key presses work like a charm. I love BTT, and use it heavily, so would obviously prefer to make this work with BTT.

** Comments **

I have searched the forum, and have found that this 'sticky' key situation has been encountered, but have not come across a suitable solution. The original poster went through the same trouble I experienced, but was told to simply use the 'send keyboard shortcut' function. As described above, this does not do anything.