"cannot open file" error for '/var/db/DetachedSignatures' in system console

Describe the bug
When I start BetterTouchTool and open Console.app there is a flood of those events:

error 11:36:27.749970 -0400 taskgated cannot open file at line 42263 of [95fbac39ba]
error 11:36:27.749989 -0400 taskgated os_unix.c:42263: (2) open(/var/db/DetachedSignatures) - No such file or directory
default 11:36:27.750064 -0400 taskgated MacOS error: -67062

These are there even after a fresh restart.
If I close BetterTouchTool, these errors stop being appended.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
No side effect on the touchbar or anything else


Device information:

  • Type of Mac: MacBookPro 15-inch 2018
  • macOS version: 10.14.4
  • BetterTouchTool version: 2.809

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Afaik DetachedSignatures is related to SQLLite, the database BTT uses via Apple's Core Data. I haven't seen such an error before, maybe your BTT database has gotten corrupted.

The error itself is probably a macOS bug, I don't think that this file is expected to be there.

Possibly try to export your BTT preset (to backup your settings), then quit BTT & delete the ~/Library/Application Support/BetterTouchTool folder, BTT will create a fresh database on next start then.

//edit: I think I'm wrong, DetachedSignatures seems to be something different related to code signatures. However I have no idea what exactly, BTT doesn't use detached signatures. On my system I can see that error e.g. for Little Snitch and even Apple's iCloudHelper.

... probably something to report to Apple.

Thanks for the quick reply.

I tried multiple things and nailed it to a 'Shell Script/Task' running with a repeat time. The error is logged whenever the script is run (it doesn't matter what the script does actually).

So it doesn't seem to be a corrupted DB.

I will continue digging into this and see if this an Apple issue.

Thanks anyway :slight_smile:

That's interesting, I'll have a look there!
Maybe there is an issue when a signed app like BTT is launching an unsigned command line tool or something like that? The code that BTT uses to execute shell scripts/tasks is very simple (only like 30 lines of code) and doesn't do anything special.

However if you don't experience other issues, you may not need to worry about this. Apple has completely changed their logging system with one of the last macOS versions, so that even thousands of continuous logs won't really impact performance (unless the console.app is open).

Agree, I was mostly curious about this behaviour :smile:

Thanks for the follow-up.