⌘C ⌘V not working in BTT

Describe the bug
⌘C and ⌘V are not working, application-wide.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
BTT main app, keyboard

Device information:

  • Type of Mac: MacBookPro15,1
  • macOS version: 10.14.5 Beta
  • BetterTouchTool version: 2.750

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Triggering the context menu items is working.

Ah sorry I had it disabled for the old UI while working on the new one. Should be back in v.2.752 (will be online in a few minutes)

1 Like

You're the man of the evening :slightly_smiling_face:
Virtual beer is being sent..... :beers:

I think related to this (both version 2.750 and 2.752 have it):
BTT terminal script editor replaces ' with ’, and ... " with “

is there a quick way to fix this myself?

Disabling "use smart quotes and dashes" in system preferences => keyboard should get rid of that.

1 Like

indeed, thanks!
did you just change the way BTT interprets quotes and dashes? just before installing the update today, I could input these as expected... terminal itself does not replace them, and it would be "smart" to not replace them in this kind of input window?

unless you are using the new ui preview, there hasn't been a change :man_shrugging:
But I'll check how i can disable this.

1 Like

I've been having trouble with Cmd/C Cmd/V copy-and-paste for a few BTT versions now.
I'm running Mojave on multiple machines, BTT version 2.750. Appears that nothing is being copied to the clipboard. In fact, just tried to copy-paste the URL from this browser window...nothing. Exiting BTT restores the expected behavior.

Possibly try 2.760 there have been many fixes.
However in your case it sounds like you have configured cmd+c and cmd+v shortcuts in BTT that override the default system shortcuts? (The original topic was about cmd+c and cmd+v not working in BTT itself)

Thanks for the quick response. I haven't configured any keyboard shortcuts, and just three global trackpad gestures. The symptom is that a Cmd-C doesn't place anything onto the clipboard; this turns up in most of the apps that I use. Most of the time clicking Cmd-C several times will 'catch'. I think this began on the first Mojave update, and I see it on three different machines.

Unfortunately I haven't hear of such an issue before thus I assume it's some configuration issue (if it was a general thing I had already received tons of emails :-)). If you want you can send me the debug information (About Tab in BTT => Export Debug Information, this will create a folder called BetterTouchToolDebug on your Desktop which you can send to andreas@folivora.ai)

@Andreas_Hegenberg

Reproduce this issue:

  1. Restart BTT.
  2. Open the new UI
  3. Use the window button to close the new UI.
  4. Open the old UI
  5. All menubar items are removed, including the copy function which is what I suspect is causing this issue.

Please fix!
Runnning 2.760

that is already on my todo list, but it only affects BTT. It sounds like @pdonham encounters copy paste issues across macOS.

I ended up doing a complete uninstall (using App Cleaner) and a reinstall, which seems to have solved the issue. I've used BTT for several years...might be that I had a corrupt plist somewhere after multiple upgrades and machine swaps.

BTW I teach CS at university, and every semester I'm asked what tool I'm using that does the 'cool snaps' and gestures durin lecture.

2 Likes

I know this is an old one but I'm having the same problem on a Macbook Pro 16".
I have restarted the entire computer as well as BTT several times. No luck.

The Cmd-A action works.
The Cmd-C does not work.

When I change the flow to only do a cmd-c, it works.
A delay between keys does not help.

1 Like

Changing the sequence to this worked

  • Cmd-A
  • Cmd-C
  • Cmd-C

Produces a beep in error but copies the text
So it seems the first Cmd-C fails, but the second one succeeds.

So then I tried
Also tried
-Cmd-A down and up
-Cmd-C down only
-Cmd-C up only
This worked THE FIRST TIME ONLY without error beeps.

Imprint | Privacy Policy