Bugs that are bugging me, #2

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
There are multiple circumstances that this happens in. Basically, the UI 'jumps' back a level when adding something new.

In a group, add a new button — the group is closed and you have to go back into the group to edit the new button.

Add the first action to the above new button — the group is closed again. It does not seem to affect any further action adds. Just the first one.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
At least Touch Bar and Stream Deck (the only ones I use).

N/A - behavioural

Device information:

  • Type of Mac: MacBook Pro M1 13" (2020)
  • macOS version: Ventura 13.1
  • BetterTouchTool version: 3.9993 (2193)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
The obvious workaround is to go back into the relevant config area.