Bug: Snap Area doesn't activate when pressing modifier key

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

How about linking to where one may find the alpha version? I'm using the latest version from the App Store.

Describe the bug
The bug is caused when you create a snap area that is only active from a modifier key (in my case the fn key). If you drag a window before pressing the modifier key and your cursor is under the snap area, then pressing the modifier key will not activate the snap area. Only after entering your cursor into a snap area while the modifier key is pressed will the snap area activate for the window being dragged.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
I'm using a MacBook Trackpad.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Mackbook Pro 16" M1 Max
  • macOS version: 12.3 (21E230)
  • BetterTouchTool version: 1.9.7

If you really want this behavior (it can be really annoying depending on your setup), there is a hidden setting that can be activated by running this terminal command while BetterSnapTool is quit:

defaults write com.hegenberg.BetterSnapTool BSTAllowInsideDragSnap YES

1 Like

I will give this a try. Thanks!