Bug: Paste as text inserts "-"

This is related to the Paste as text functionality of the Clipboard: when using the Paste Plain Text feature I get "-". I couldn't reduce this behavior to specific type of content in the clipboard or specific apps. I also haven't been able to reproduce it with other clipboard managers (e.g. Pastebot).

By searching the forum I have found a similar report that pinpointed this behavior to the Office Suite.

Is this a known issue? Are there any known workarounds or something I could try?

thank you,

If this only happens in office applications, try to check this in the clipboard manager settings:

There have been some office versions that were buggy and caused performance issues when accessing the plain text clipboard item - it has been a while, possibly this has been fixed by now.

@Andreas_Hegenberg I just reproduced the bug :-). It is related to the Universal clipboard. I have copied an URL on the iPhone. When attempting to paste it on my macOS it shows up as -.

Pastebot recognizes it even if it's displaying "Clipping from Safari".

Keyboard Maestro displays the URL.

I hope this will help fixing it. Thank you

I came back to reconfirm that the bug is related to Universal Clipboard. The bigger problem is that somehow bringing up BTT clipboard manager corrupts the clip and then it cannot be pasted anymore.

@Andreas_Hegenberg any chance you could look into this? I don't know how many BTT users are relying on the BTT clipboard manager and I really hope you'll be able to track it down.

thank you,

I tried to reproduce it, but it's working fine here with universal clipboard and URLs from Safari. Is there anything other than that, that might be special?

Maybe try other types of links from other apps (Overcast, Podcasts)?

Any of these show as - on the BTT clipboard on Macbook.

Is there a way to check the “original”? (This is a new machine on which I haven’t installed KeyboardMaestro or Pastie as part of an attempt to simplify)

Or any configuration or debug log?

What could I try? I am trying to figure out how I could eliminate any external causes, but I come empty.

Unfortunately I don't know.

I tried with other apps (e.g. Podcasts) but it also seems to work fine here. Which version of macOS and BTT are you running?

Here's what I tried:

  1. click on Safari URL bar and copy -> works ok
  2. click on Safari share button and then Copy -> failed
  3. select some text in Safari and then Copy -> works ok

I am running latest versions of everything :smiley:

  • macOS 14.2.1
  • iOS 17.2.1
  • BTT 4.356

I have recorded the screen with the above, but I don't think it will help in any way.

The more I played with it, the more it looks like it's related to the Copy action in the Share sheet.

I don't know anything about how or what is supposed to do but my hypothesis is that the Copy in Share sheet puts a more complex object in the clipboard than simple text. And that's breaking in BTT.

Would that be possible? Even remotely?

that might be possible, I’ll check!

Side to side: Pastebot and BTT clipboard. This makes it clear that BTT has an issue dealing with Universal Clipboard items coming through the Share sheet -> Copy action.

v 4.373 alpha should now show the copied URL (however it doesn't yet show that it was copied on the iOS device)

The source of the clipboard item is not that important IMO. I feel Pastebot is doing that way because the clipboard item has more metadata in it. At this time I can't say I see a way to use it.