Bug: HUD Overlay disappears too quickly on main display, shows for correct amount of time on secondary display

Describe the bug:

In a recent update (not sure which one) the HUD Overlay has a new bug when enabled for keyboard shortcuts on macOS Monterey 12.6.3

I have a 2 display setup. When the keyboard shortcut is pressed, the HUD Overlay disappears on the main display way too quickly. However on my second display, the HUD Overlay is showing for the correct amount of time which is much easier to see. I can just barely see what the HUD Overlay says on my main display because it disappears too quickly.

I have tried both options, first the "Show HUD Overlay when shortcut is triggered" checkbox and second, adding the "Show HUD Overlay" as a separate action with the first option checkbox disabled.

When I try adding the "Show HUD Overlay" as a separate action, it allows me to configure more options such as the duration to show the HUD Overlay. As a test I set this to 10 seconds. When the keyboard shortcut is pressed, the HUD Overlay disappears quickly on my main display, but on the second display it shows for 10 seconds like I configured it. So this rules out the bug being with only one of the options. It happens with both of the ways to setup a HUD Overlay to be shown with a keyboard shortcut.

I also tried switching the main focus to the secondary display (active window on secondary display using mouse and keyboard) and the same thing happens. Quickly disappears on main display, and stays for the correct amount of time on the secondary display. My main display is the left screen and my second display is the right screen if that helps.

I noticed in the release notes that recently for macOS Ventura there are now more customization options for the HUD Overlay, but only for macOS Ventura. That's understandable, but I am not quite ready to upgrade yet. I think something in the update created a new bug for macOS Monterey. Maybe someone can test this out to see if it's just a Monterey bug or affects Ventura too. I haven't installed any new apps recently so I'm pretty sure it's not caused by another app I have running.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Keyboard shortcuts

Device information:

  • macOS version: Monterey 12.6.3
  • BetterTouchTool version: 4.0.23 (updated to latest alpha and still have this bug)



I've been using BetterTouchTool for many years and I love it! Keep up the great work! :slightly_smiling_face:

That sounds like a bug, I'll have a look!

1 Like

Thank you! I appreciate it! :slightly_smiling_face:

Thank you! :slightly_smiling_face:

I just updated to alpha version 4.0.24 and this bug seems to be fixed.

I will post back if for some reason it acts up again.

:+1: thanks for confirming

1 Like