Bug? BTT will not take control of StreamDeck

Hi,

long time user of BTT. Recently bought a Stream Deck (in no small part because I heard it worked with BTT :blush: ) but unfortunately I cannot get them to work together.

I hesitate to call this a "bug" since I don't know the reason, but whatever the problem it unfortunately stops me from using it as planned.

Description:

Using BTT to "fully control" Streamdeck (which I'd prefer!) results in absolutely nothing: Any button from Streamdeck's own app will go away, and the screen is replaced with the screensaver logo.
No additions in BTT shows up on the screen regardless of what I restart and in what order.

Using Streamdecks app instead (less desirable, but okay) I can in fact add BTT buttons -- but as soon as I want to configure one, and Streamdeck tries to launch/call BTT, BTT will crash every time.

System info:
*I do own a license since back when I first learned about the app, but am also a SetApp user and nowadays the actual install is from the SetApp distribution if that makes any difference. Exact version is 3.962, 2128

  • I'm on MacOS Monterey, a 2019 Intel i9 with 32GB memory
  • The stream deck is an XL

All thoughts and help appreciated!

Some additional information: After installing the build from this site, the problem is still the same.

This time, the first crash comes after MacOS asking me to allow BTT access to "the confidential information in BTTAllowExternalURLScripting" -- and as soon as I click yes BTT will crash.

Interestingly, this stops me from ever getting BTT buttons shown in the StreamDeck at all, which I did momentarily succeed with before reinstalling BTT...

So -- I'm relatively new to these forums -- does no answer mean that my question is ill-phrased, or that there is no answer?

Please let me know if I need to provide more info. Or in case I have missed something vital and should just RTFM, please let me know that too (and if possible point me in the right direction).

/F.

I have an XL and a Plus and they both run fine in both plugin and standalone mode. The Plus is not yet 100% supported (the touchbar is not yet active). So I can't offer any solution to your problem. It must be something with your configuration. However, I am only a user and forum member.

Upgraded to Ventura, but the problems persist.

BTT will still not take control of the deck (repeatedly asks to restart if I click the radio button) and if doing it the other way around, clicking any BTT button in the configurator will result in BTT crashing.

These are the first couple of lines of the crash report, here's hoping @Andreas_Hegenberg can make something out of it.

-------------------------------------
Translated Report (Full Report Below)
-------------------------------------

Process:               BetterTouchTool [60856]
Path:                  /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool
Identifier:            com.hegenberg.BetterTouchTool
Version:               3.962 (2127)
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Date/Time:             2022-12-19 14:01:04.0920 +0100
OS Version:            macOS 13.1 (22C65)
Report Version:        12
Bridge OS Version:     7.1 (20P2059)
Anonymous UUID:        CDD89693-DBF9-5743-2FD7-316DE9C64F7C

Sleep/Wake UUID:       F6847F35-2F63-4DFE-9634-D7B0408EC118

Time Awake Since Boot: 60000 seconds
Time Since Wake:       465 seconds

System Integrity Protection: enabled

Crashed Thread:        8  Dispatch queue: com.apple.root.user-initiated-qos

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called


Application Specific Backtrace 0:
0   CoreFoundation                      0x00007ff810eb840b __exceptionPreprocess + 242
1   libobjc.A.dylib                     0x00007ff810a04e25 objc_exception_throw + 48
2   CoreFoundation                      0x00007ff810ee05b6 _CFBundleGetValueForInfoKey + 0
3   AppKit                              0x00007ff813fb0584 -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 307
4   AppKit                              0x00007ff813f9d353 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1247
5   AppKit                              0x00007ff813f9ce6d -[NSWindow initWithContentRect:styleMask:backing:defer:] + 42
6   AppKit                              0x00007ff813f9b38b -[NSWindowTemplate nibInstantiate] + 354
7   AppKit                              0x00007ff813f69822 -[NSIBObjectData instantiateObject:] + 222
8   AppKit                              0x00007ff813f68f94 -[NSIBObjectData nibInstantiateWithOwner:options:topLevelObjects:] + 476
9   AppKit                              0x00007ff813fdf4eb -[NSNib _instantiateNibWithExternalNameTable:options:] + 656
10  AppKit                              0x00007ff813fdf166 -[NSNib _instantiateWithOwner:options:topLevelObjects:] + 143
11  AppKit                              0x00007ff8148003ff -[NSStoryboard _instantiateControllerWithIdentifier:creator:storyboardSegueTemplate:sender:] + 470
12  BetterTouchTool                     0x000000010209fd63 -[BetterTouchToolAppDelegate showNewPreferences] + 688
13  libdispatch.dylib                   0x00007ff810be37fb _dispatch_call_block_and_release + 12
14  libdispatch.dylib                   0x00007ff810be4a44 _dispatch_client_callout + 8
15  libdispatch.dylib                   0x00007ff810bf47f6 _dispatch_root_queue_drain + 683
16  libdispatch.dylib                   0x00007ff810bf4e4d _dispatch_worker_thread2 + 160
17  libsystem_pthread.dylib             0x00007ff810d60c9d _pthread_wqthread + 256
18  libsystem_pthread.dylib             0x00007ff810d5fc67 start_wqthread + 15


Thread 0::  Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	    0x7ff8109f4ee6 getMethodNoSuper_nolock(objc_class*, objc_selector*) + 368

I haven’t seen such a crashlog before, it kind of sounds like your copy of BTT is missing some files. Possibly try deleting it and replacing it with a fresh downloaded one (folivora.ai - Great Tools for your Mac!)

Hi Andreas, thanks for your reply.

As it happens, the problems started with the copy of BTT that was installed by SetApp (and which has worked flawlessly except for the Streamdeck)
I have since uninstalled the SetApp version and downloaded/installed your "own" distribution from here, to no avail.
Can you tell from the crashlog what files seem to be missing?

What I had not done though, was to install the latest alpha β€” which I did now!
Doing so, I still cannot make BTT take control over the deck (the screensaver image appears and will not go away until I choose to run BTT as a plugin again)
Also, clicking "open BTT for configuration" within the StreamDeck app, still crashes Beat.

But: What has improved though, is that instead of BTT logos, buttons in the StreamDeck app that are made with the custom/BTT plugin, do appear as designed in BTT. (Before, they only appeared as BTT logos on black, and didn't perform any action).

It seems as whatever you did to reload buttons (?) has helped them being properly loaded for me to.

So... now at least it is somewhat useful -- but two out of three (taking full control, and using the open BTT to configure button) are still unsuccessful for me...

I have a similar problem. I configured BTT to take over control of the Streamdeck. I noticed that BTT (SetApp version) wil crash when the Streamdeck app is running. When I do the following dance:

  • quit BTT
  • start Streamdeck app
  • quit Streamdeck app
  • start BTT

BTT takes over and it works flawlessly. However, I have to do this dance every time I (re)boot my laptop (also 2019 Intel). So my question would be if I uninstall the Streamdeck app, will I be able to still use BTT to control my Streamdeck or does BTT need some drivers that the Streamdeck app provides?

BTT doesn't need the StreamDeck app - so you could remove it. However it should still not crash. I'll have a look!

Found & fixed the issue. Will not crash with the next version anymore.

1 Like