BTT would not start after configuring bluetooth LE trigger

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
I just started to configure a new trigger on Bluethooth LE (Experimental) ... before i finished configuring it, BTT crashed and would. not restart. I rebooted my machine ant it still would not start.

Eventually i managed to click on the configuraiton menu before it crashed on starting up and obtained the stacktrace below.

To fix the issue i had to go to my privacy settings and grant access to bluetooth to BTT ... i should have been promped to do this when i started using that trigger... or at least BTT should not have crashed.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro 2018
  • macOS version: Ventura 13.1
  • BetterTouchTool version: 3.402 (1633)
    Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Staktrace snipeet

"sip" : "enabled",
"exception" : {"codes":"0x0000000000000000, 0x0000000000000000","rawCodes":[0,0],"type":"EXC_CRASH","signal":"SIGABRT"},
"termination" : {"flags":518,"code":0,"namespace":"TCC","details":["This app has crashed because it attempted to access privacy-sensitive data without a usage description. The app's Info.plist must contain an NSBluetoothAlwaysUsageDescription key with a string value explaining to the user how the app uses this data."]},
"extMods" : {"caller":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"system":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"targeted":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"warnings":0},
"faultingThread" : 7,
"threads" : [{"id":18463,"queue":"","frames":

Unfortunately recent macOS versions require a change which was not available in the BTT version you are running (v3.402 is from 2020). Upgrading BTT should solve this.