BTT won't open on High Sierra after latest update

Describe the bug
Updated to the latest version pushed out today and now BTT will not open. I get a popup that says "The application “” can’t be opened." every time I try to open it

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Not sure, BTT won't open

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro 17" Mid 2010
  • macOS version: 10.13.6
  • BetterTouchTool version: not sure of version number, but is the latest update

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

hey, maybe something went wrong during the update process. Have you tried to re-download via

That worked. I thought about doing that before posting here, but didn't want to mess things up any further. Appreciate the help and quick response!!